Our team has resolved this issue regarding setting up reoccurring campaigns and all services are now responding normally.
Customer impact:
Any user whose Acoustic Ids were enabled for IP warming would encounter an error during configuration of a reoccurring campaign. This was first reported around 10:45am EST and resolved by 3:30pm EST.
We apologize for any inconvenience you may have experienced due to this issue.
Posted Mar 03, 2026 - 18:29 EST
Monitoring
Our team has resolved this issue with configuring reoccurring campaigns within Connect.
Customer impact:
Any user whose Acoustic Ids are enabled for IP warming would encounter an issue during configuration of a reoccurring campaign.
We apologize for any inconvenience you may have experienced due to this issue.
Posted Mar 03, 2026 - 16:50 EST
Investigating
Our team continues to actively investigate the failure when scheduling a reoccurring campaign.
Customers impact:
Any user whose Acoustic Ids are enabled for IP warming will encounter an issue during configuration of a reoccurring campaign. They will receive an 'Error : fix the error before proceeding' message.
We apologize for any inconvenience you may be experiencing due to this issue.
Posted Mar 03, 2026 - 14:51 EST
This incident affected: Acoustic Connect - US (Email), Acoustic Connect - EU (Email), and Acoustic Connect - AP (Email).