Campaign Mailing Status Issue Under Investigation POD 5

Incident Report for Acoustic Public Service Status

Resolved

This incident has been resolved.
Posted Sep 14, 2025 - 04:04 EDT

Monitoring

Our team has identified the cause of the issue, and rectified the problem. We are continuing to monitor the situation.

Customer Impact:
Mailings status are accurately reflected. Mailings are proceeding at normal pace.

We apologize for the inconvenience and appreciate your patience.
Posted Sep 14, 2025 - 02:19 EDT

Update

Our team is continuing to investigate the issue and will follow-up with more information soon.
Posted Sep 13, 2025 - 22:38 EDT

Investigating

We are currently investigating an issue with the Acoustic Campaign service on POD 5. Some mailings may show running status despite being completed. Acoustic team is currently investigating and will follow-up with more information soon.

We apologize for any inconvenience you may be experiencing due to this issue.
Posted Sep 13, 2025 - 20:30 EDT
This incident affected: Acoustic Campaign - POD 5 (Email).